Cladonia, proud developers of the Exchanger XML Editor

Cladonia - simplifying XML!

Home News Links About Contact

Overview
Features
FAQ
Online Help
Getting Started
Menus
Preferences
Toolbars
Download
Extensions
Evaluate
Buy
User Forum

Platforms
The Exchanger XML Editor runs on all platforms:
Windows
Linux
Mac OS X
Any Unix Platform
Other Java Enabled Platforms

Further Information
For more information download the User Guide.
  User Guide (A4) (3.4MB)
  User Guide (US) (3.4MB)
  What's New (833KB)

Newsletter
Subscribe to Newsletter
Keep up to date with our latest product releases by subscribing to our newsletter.

Edit Menu

Undo Reverses the last edit. Undo can be used repeatedly to rollback a number of changes. Ctrl+Z
Redo Reverses the last Undo operation. Redo can be used repeatedly to rollback a number of Redo operations. Ctrl+Y

Cut Cuts the current selection so that it can be moved to another location. Ctrl+X
Copy Copies the current selection so that it can be pasted to another location. Ctrl+C
Paste Pastes content that has previously been Cut or Copied. Ctrl+V

Add In the Outliner, creates the instance of the current node. ENTER
Delete In the Outliner, deletes the current node. DELETE
Create Required Nodes In the Outliner, this toggle controls whether required elements are automatically created.

Indent Indent a block of content
Unindent Unindent (or exdent) a block of content.

XML A menu containing a series of editing functions
    Select Element Selects the current element for the cursor position. Used repeatedly, selects the content of all ancestors up to the root element. Ctrl+E
    Select Element Content Selects the current element content (without start and end tags) for the cursor position. Ctrl+Shift+E
    Split Element Inserts an end tag and new start tag for the current element at the cursor position.
    Insert Special Character Displays a popup window with a range of characters that can be inserted at the cursor position as named entities, character references or actual character occurrences. Ctrl+I
    Convert Entities to Characters Displays a popup window that allows the user to specify how to replace named entities in the current selection with character references or actual character occurrences.
    Convert Characters to Entities Displays a popup window that allows the user to specify how to replace character occurrences in the current selection with character references or names entities.
    Strip Tags Removes start and end tags from the current selection.
    Tag Surrounds an existing piece of content with an elementstart and end tag. Simply highlight the piece of content and select Edit->XML->Tag (or press the Tag button). Enter the desired element name in the pop-up dialog box. Ctrl+T
    Repeat Last Tag Surrounds a piece of content with the same tag as the last time you used the Edit->XML->Tag function. Ctrl+Shift+T
    Rename Element Changes the start tag and the end tag for the current element. Ctrl+R
    Expand Empty Element Replaces an empty element with the corresponding start and end tag. Ctrl+L
    Comment Comment an existing content block. Simply highlight the content and select Edit->Comment (or press the Comment button). Ctrl+K
    CDATA Create a CDATA section for an existing content block. Simply highlight the content and select Edit->CDATA (or press the CDATA button).
    Lock Locks the active document so that all element names in start and end tags will no longer be editable (only attribute values and text content can now be modified.
    Format Format the active document accoring to the current format settings. To control the format settings, select File->Preferences and go to the Format tab.
    Goto Start Tag Highlight the start tag for the current cursor position. Ctrl+Up Arrow
    Goto End Tag Highlight the end tag for the current cursor position. Ctrl+Down Arrow
    Goto Previous Attribute Value Move the cursor into the value field of the previous attribute. Ctrl+Shift+Up Arrow
    Goto Next Attribute Value Move the cursor into the value field of the next attribute. Ctrl+Shift+Down Arrow
Insert Fragment Shows the Fragment popup list, if the current document has a Type with Fragments defined. Ctrl+Shift+Space

Toggle Bookmark Create a bookmark on the current line. If a bookmark already exists on the current line, remove it. Ctrl+B
Select Bookmark Choose a bookmark from a popup list of all bookmarks. Ctrl+Shift+B

Goto Go to a line number. Enter the line number in the pop-up dialog and press OK (or the Enter key). To turn line numbering on or off in the Editor select File->Preferences, go to the Views tab and set/reset the Show Line Numbers field in the Editor section. Ctrl+G

Find Displays the Find dialog. Ctrl+F
Find Next Repeats the current search. F3
Replace Displays the Replace dialog. Ctrl+H
Find in Files... Search in one or more directories on the filesystem.