Cladonia, proud developers of the Exchanger XML Editor

Cladonia - simplifying XML!

Home News Links About Contact

Overview
Features
FAQ
Online Help
Getting Started
Menus
Preferences
Toolbars
Download
Extensions
Evaluate
Buy
User Forum

Platforms
The Exchanger XML Editor runs on all platforms:
Windows
Linux
Mac OS X
Any Unix Platform
Other Java Enabled Platforms

Further Information
For more information download the V3.1 User Guide.
  User Guide (A4) (2.19MB)
  User Guide (US) (2.18MB)
  What's New (833KB)

Newsletter
Subscribe to Newsletter
Keep up to date with our latest product releases by subscribing to our newsletter.

Browsing/Navigation

To open a sample file, double-click on the Browsing/Navigation project and then double-click on the file simple.xml. (Alternatively, choose File->Open (or click the Open File icon) and select the file projects/Browsing Navigation/simple.xml). The file contents are displayed in the Editor view by default.

Viewer

Switch to the Viewer by selecting View->Viewer or by clicking on the Viewer button on the upper right-hand side of the application.

View Buttons

Figure 1. View Buttons

Collapse the Viewer tree by clicking the Collapse All Nodes button () or by choosing View->Collapse All.

To collapse an individual node, click on the appropriate minus icon (-) in the Viewer window.

Expand the Viewer tree by clicking the Expand All Nodes button ()or by choosing View->Expand All.

To expand an individual node, click on the appropriate plus icon (+) in the Viewer window.

The Viewer is convenient for browsing and rapidly navigating the element structure. By default the Viewer will show attribute names and values, text content, namespaces and comments. Choose View->View Properties to change which details should be shown in the Viewer.

To toggle between the Viewer and Editor windows, click the appropriate Viewer and Editor buttons on the upper right-hand side of the application - alternatively use the View menu and choose View->Editor or View->Viewer.

Synchronisation

By default, the content in the Viewer window and the Editor window is synchronised - clicking within a particular node in the Editor will automatically cause the same node to be highlighted in the Viewer (expanding the tree if necessary). Similarly, selecting a node in the Viewer tree will move the cursor in the Editor to the corresponding place in the file. (Synchronisation can be turned off using View->Synchronise Selection window).

Multiple Documents

Multiple documents can be opened simultaneously - switching between open documents is achieved by clicking on the appropriate tab at the bottom of the Editor or Viewer window. The view mode is maintained for each open file, so one can be in Editor mode and another can be in Viewer mode. To easily switch between open documents, choose View->Select Document.... If multiple documents are open concurrently, a list is displayed that can be traversed using the up and down arrow keys, or alphabetically by typing in the first letter of the document you would like to open. Press Enter once the required file is highlighted. Alternatively, using the keyboard, hold the Alt key down and press the number 1 repeatedly to traverse the list (if only 2 documents are opened, pressing Alt-1 automatically switches to the other document.

File Close

To close an open file, choose File->Close or right-click on the main window or on the appropriate tab at the bottom, and select Close from the popup menu.

Start Browser

If the active document is an (X)HTML file, choose Tools->Start Browser or press F9 to open the file in your default browser. Linux users can change the default browser from Mozilla, using a Linux-specific setting in the System tab in the File->Preferences dialog - an application restart is required for any changes to come into effect.

Clean Up HTML

Choose Tools->Clean Up HTML to convert arbitrary HTML content to XML.