Cladonia, proud developers of the Exchanger XML Editor

Cladonia - simplifying XML!

Home News Links About Contact

Overview
Features
FAQ
Online Help
Getting Started
Menus
Preferences
Toolbars
Download
Extensions
Evaluate
Buy
User Forum

Platforms
The Exchanger XML Editor runs on all platforms:
Windows
Linux
Mac OS X
Any Unix Platform
Other Java Enabled Platforms

Further Information
For more information download the User Guide.
  User Guide (A4) (3.4MB)
  User Guide (US) (3.4MB)
  What's New (833KB)

Newsletter
Subscribe to Newsletter
Keep up to date with our latest product releases by subscribing to our newsletter.

Getting Started with Exchanger XML Editor

Overview

Exchanger XML Editor now comes in two editions. Exchanger XML Lite is free for use in non-commercial environments and can be downloaded without registration from www.freexmleditor.com or www.exchangerxml.com. Exchanger XML Professional Edition contains enhanced functionality not available in the Lite version and requires registration for a 30-day trial, after which a Commercial or Academic/Non-Profit license must be purchased.

Exchanger XML Editor contains the following core functionality:

  • Editor: for text-based editing of tags and content.

  • Grid: for tag-free editing of XML data (Professional Edtion only).

  • XSLT Debugger: for integrated or stand-alone debugging of style sheets

  • XML Differencing and Merging: for comparing and reconciling multiple document versions (Professional Edtion only).

  • Viewer: for browsing/navigating an XML document in a tree view.

  • Schema Viewer: for browsing/navigating an XML Schema.

  • Outliner: for Schema-aware editing of XML data without entering tags.

Downloading Exchanger XML Professional Edition

Download the software from the website at www.exchangerxml.com/editor/downloads.html. Exchanger XML Editor requires Java 1.4 or higher. If you do not already have Java installed on your computer, download a version with a Java Virtual Machine included.

Installation Instructions

Windows:

After downloading, double-click on xngrproV32_windows_jvm.exe or xngrproV32_windows_nojvm.exe

Linux:

After downloading, open a shell and cd to the directory where you saved the installer. At the prompt type: sh ./xngrproV32_linux_jvm.bin or sh ./xngrproV32_linux_nojvm.bin

Mac OS X:

After downloading, double-click xngrproV32_macosx Note: The compressed installer should be recognized by Stuffit Expander and should automatically be expanded after downloading. If it is not expanded, you can expand it manually using StuffIt Expander 6.0 or later.

Other Unix:

After downloading, open a shell and cd to the directory where you saved the installer. At the prompt type: sh ./xngrproV32.bin

Other Java Enabled Platforms:

After downloading, change to the directory where you saved the installer. At the prompt type: java -jar xngrproV32.jar

Registering for an Evaluation License

To use the Exchanger XML Editor you must obtain a valid license-key. This is available from www.exchangerxml.com/editor/evaluate.html. The Evaluation license-key is free and will be valid for 30 days.

To generate the Evaluation License-key please provide your first name, last name and email address. We guarantee not to share this information with any other organisation and will only contact you with news of our next release, at which time you may opt out of any further mailings. Please read our Privacy Policy document for more information. See www.cladonia.com/pps.htm for an online copy of the Privacy Policy Statement.

The license-key will be sent to you via email. Please read the instructions contained within this email and paste the license-key into the license dialog box when starting the Exchanger XML Editor.

 -----------COPY BELOW THIS LINE-----------------------

 Product_Name: Exchanger XML Editor
 Product_Version: 3.2
 First_Name: Tom
 Last_Name: Jones
 User_Email: tjones@exchangerxml.com
 Creation_Date: 2005-05-06
 License_Type: Temporary
 Sign:
302c02141a0ee3a6c4a1d5cb0384400dc8045c57d263dc2f02145d709
c11f181499831a63e80621a91e9ebf90a42
 Comment: 30 day Evaluation License
 Max_Expiry_Days: 30

 -----------COPY ABOVE THIS LINE-----------------------	
				

The evaluation software is fully functional and during the evaluation period technical support is available through the online forums at the website or via email to support@cladonia.com.

If you have any problems registering for the Evaluation License or you would like to extend your evaluation period beyond 30 days, please contact us at support@cladonia.com.

Running the Software and Installing the Evaluation License

Startup the software in the normal means for the host platform (for example, using the Start menu on Windows) . Alternatively, you can startup from the commandline as outlined in the next section.

Starting up for the first time, you will need to paste the license from the email into the License Dialog.

Pasting the License in the Dialog

Figure 1. Pasting the License in the Dialog

Running from the command line

To run the Exchanger XML Editor from the command line, for example if you want to change the memory settings, move to the install directory and use a command similar to:

java -jar lib\xngr-loader.jar

or if you downloaded a version with the JVM included:

.\jre\bin\java -jar lib\xngr-loader.jar

To run the XSLT Debugger in stand-alone mode from the command line, move to the install directory and use the -debugger option as in:

java -jar lib\xngr-loader.jar -debugger

or if you downloaded a version with the JVM included:

.\jre\bin\java -jar lib\xngr-loader.jar -debugger

It is recommended that at least 128MB memory is available when running Exchanger XML Editor. To increse the memory available, use a command similar to:

java -Xms256m -Xmx512m -jar lib\xngr-loader.jar

Upgrading from Version 3.1

If you have previously installed version 3.1, simply install the new release in a different directory. Your settings will automatically be imported into the new version. If you already have a valid license, there is no need to get a new license for this upgrade.

Documentation

All the documentation for Exchanger XML Editor is available for download from the website at www.exchangerxml.com/editor/library.html.

The User Guide can be downloaded as a single large PDF or in smaller sections, in both US Letter and A4 format.

The library contains numerous videos demonstrating how to use specific features of the product. These videos are in Flash format and should be viewable on most platforms.

The software also has a comprehensive help system that is available through the Help entry on the main menu.

Examples

Projects provide a convenient means for managing related groups of documents. The projects view is the first of the three tabs on the left-hand panel in the editor and on installation will contain a number of sample projects for SOAP, WSDL, XML Signatures, etc.

The files used in this document are all located in the projects directory where you installed Exchanger, for example, in the typical Windows intallation this would be C:\Program Files\Exchanger XML Editor 3.1. Please adapt the directory and file specifications for your environment.

If you delete some or all of the sample projects, they can easily be reinstated using the Import Project functionality. To recreate all the projects, choose Project->Import Project and select the file projects/all.projects. Alternatively, to import a single project, for example, the XPath project, import the project file projects/XPath/xpath.xngr.

Preferences and Settings

To change settings in the Editor, select File->Preferences and navigate through the different tabs. The preferences are documented at the end of this Guide. User settings are stored in a file called .xngr-editor-v32.xml in the .xngr sub-directory of the user's home directory. Make sure to back up this file when installing new versions of the software. This directory also contains an error file .xngr-editor.err and a log file .xngr-editor.out

Frequently changed settings are made available on the menus so that they are easier to access and also to allow shortcuts to be created. For example, Editor properties such as showing line numbers, content folding and soft-wrapping are now available using the View->Editor Properties sub-menus, while the Grid is configurable using the View->Grid Properties sub-menus. Shortcuts for all these properties can be created in the normal way via the Keys tab in the Preferences dialog.

To maximize the screen real estate for editing a file, double-click on the tab for the filename in the editor. Alternatively, click on the small triangle that is pointing left on the vertical splitter between the Main Window and the Left-Hand Window to hide the Controller. Also click on the downwards-pointing small triangle on the horizontal splitter beneath the Main Window to hide the Output Window. The hidden components can be reinstated by reversing the procedure.

Support

Support is available via the online forums at www.exchangerxml.com. Alternatively, mail your query to support@cladonia.com

New in Version 3.2

This version is primarily a maintenance release - new/improved functionality includes:

  • Edit/Save now supported in XSLT Debugger

  • Find in Files added (in addition to Find in Projects)

  • Virtual Folders in Projects (links to directories on filesystem)

  • Improved Schema Instance Generation to support more complex schema.

  • Grid Toolbar can be moved/hidden to maximise screen real estate.

Java 1.5

Exchanger XML has been tested on Windows and Linux under Java 1.5. In general the software works as expected, but there are a number of known issues surrounding loss of focus with some of the new versions of Java, particularly, Java 1.5.0_03. If you experience such problems, please try an earlier release, or revert back to 1.4.

Look and Feel

The Look and Feel can be changed to improve the user interface experience. In particular, the default Motif Look and Feel under Java 1.4 is not very inspiring and should probably be changed. On Windows, the JGoodies options are recommended, while on Linux the Kunsttoff version is better. Note that under Java 1.5, the default Motif Look and Feel has been significantly improved and should prove suitable.

To change the Look and Feel, select File->Preferences and on the System tab, select an option from the drop down list. Save the changes and then exit the application and then restart for the new Look and Feel to take effect.

Acknowledgements

Cladonia Ltd. would like to thank Ovidiu Predescu and Tony Addyman for their permission to use code from XSLT-Process (see http://xslt-process.sourceforge.net/) in the XSLT Debugger. We would also like to acknowledge the use of software from Michael Kay (The Saxon XSLT and XQuery Processor from Saxonica Limited, www.saxonica.com ), Ken Holman (UBL stylesheets) and Yuan Wang (XDiff). The grid software is based on components licensed from JBC Solutions (www.jbcsolutions.com)

Versions

The following versions of software are included in the Exchanger XML product:

Table 1. Software Versions

Product Version
Saxon (XSLT 1) 6.5.4
Saxon (XSLT 2 + XQuery) 8.5.1
Xerces 2.7.1
Xalan 2.5.2
Apache Batik 1.6
Apache XML Security 1.1