Cladonia, proud developers of the Exchanger XML Editor

Cladonia - simplifying XML!

Home News Links About Contact

Overview
Features
FAQ
Online Help
Getting Started
Menus
Preferences
Toolbars
Download
Extensions
Evaluate
Buy
User Forum

Platforms
The Exchanger XML Editor runs on all platforms:
Windows
Linux
Mac OS X
Any Unix Platform
Other Java Enabled Platforms

Further Information
For more information download the User Guide.
  User Guide (A4) (3.4MB)
  User Guide (US) (3.4MB)
  What's New (833KB)

Newsletter
Subscribe to Newsletter
Keep up to date with our latest product releases by subscribing to our newsletter.

Debugger Toolbar

The Debugger toolbar is only visible in the Debugger view. It consists of 10 buttons.


Debugger Toolbar

Debugger Toolbar


Start Debugging Session
Use Start/Continue to commence a transformation - ensure that you have a breakpoint set or the transformation will automatically run to completion. Once the processor has been paused, use the Start/Continue button to run the transformation until the next breakpoint or until the end of the transformation is encountered.

Run to End
Use Run to End to complete the transformation without stopping at any enabled breakpoints.

Pause Debugger
Use Pause to interrupt a long-running transformation. When the debugger pauses, all the variables, parameters, stacks and traces will be setup correctly and you can continue execution from that point using any of the stepping or continue functions.

Stop Debugger
Use Stop to instantaneously stop a long-running transformation - note that no information relating to the transformation will be retained and you will not be able to recommence the processing without starting at the begining again.

Step Into
Use Step Into to step element-by-element through a style sheet. The Exchanger XSLT Debugger is different in this case from most others in that it allows you to step through start and end tags, providing a much more logical debugging experience compared to line-by-line operation. On encountering xls:apply-template or xsl:call-template instructions, the debugger will move the current position to the first instruction in the appropriate template. Step Into can be used at the very start of a transformation to step to the very first instruction that is executed. Note that when using Xalan, using Step Into at the beginning of a transformation will move processing to the first template it encounters, whereas Saxon will allow you to step through any parameters or global variables you may have in your stylesheet.

Step Out
Use Step Out to complete execution of the current template and move to the next instruction. Again, the Exchanger XSLT Debugger is different here from other products in that it restricts the Step Out functionality exclusively to templates, making the functionality more intuitive.

Step Over
Use Step Over when positioned at xsl:apply-template or xsl:call-template instructions so as to completely execute the appropriate template (without stepping into it) and to move to the next instruction.

Find
Use the Find button (or select Edit->Find or use the key combination Ctrl-F) to display the Find dialog. This allows the user to specify the search string, choose to Match Case (by default, No) and specify that the search string is a Regular Expression (by default, No) and the direction of the search (by default, Down).

Find Next Button
Use the Find Next button (or select Edit->Find Next or use the function key F3) to repeat the current search.

Goto Button
Use the Goto button (or select Edit->Goto) to go to a particular line number. Enter the line number in the pop-up dialog and press OK (or the Enter key). To turn line numbering on or off in the Editor select File->Preferences, go to the Views tab and set/reset the Show Line Numbers field in the Editor section.